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Legal Information and Disclaimers

AMBIQ MICRO INTENDS FOR THE CONTENT CONTAINED IN THE DOCUMENT TO BE ACCURATE AND RELIABLE. THIS
CONTENT MAY, HOWEVER, CONTAIN TECHNICAL INACCURACIES, TYPOGRAPHICAL ERRORS OR OTHER MISTAKES.
AMBIQ MICRO MAY MAKE CORRECTIONS OR OTHER CHANGES TO THIS CONTENT AT ANY TIME. AMBIQ MICRO
AND ITS SUPPLIERS RESERVE THE RIGHT TO MAKE CORRECTIONS, MODIFICATIONS, ENHANCEMENTS,
IMPROVEMENTS AND OTHER CHANGES TO ITS PRODUCTS, PROGRAMS AND SERVICES AT ANY TIME OR TO
DISCONTINUE ANY PRODUCTS, PROGRAMS, OR SERVICES WITHOUT NOTICE.

THE CONTENT IN THIS DOCUMENT IS PROVIDED "AS IS". AMBIQ MICRO AND ITS RESPECTIVE SUPPLIERS MAKE NO
REPRESENTATIONS ABOUT THE SUITABILITY OF THIS CONTENT FOR ANY PURPOSE AND DISCLAIM ALL
WARRANTIES AND CONDITIONS WITH REGARD TO THIS CONTENT, INCLUDING BUT NOT LIMITED TO, ALL IMPLIED
WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-
INFRINGEMENT OF ANY THIRD PARTY INTELLECTUAL PROPERTY RIGHT.

AMBIQ MICRO DOES NOT WARRANT OR REPRESENT THAT ANY LICENSE, EITHER EXPRESS OR IMPLIED, IS GRANTED
UNDER ANY PATENT RIGHT, COPYRIGHT, MASK WORK RIGHT, OR OTHER INTELLECTUAL PROPERTY RIGHT OF
AMBIQ MICRO COVERING OR RELATING TO THIS CONTENT OR ANY COMBINATION, MACHINE, OR PROCESS TO
WHICH THIS CONTENT RELATE OR WITH WHICH THIS CONTENT MAY BE USED.

USE OF THE INFORMATION IN THIS DOCUMENT MAY REQUIRE A LICENSE FROM A THIRD PARTY UNDER THE
PATENTS OR OTHER INTELLECTUAL PROPERTY OF THAT THIRD PARTY, OR A LICENSE FROM AMBIQ MICRO UNDER
THE PATENTS OR OTHER INTELLECTUAL PROPERTY OF AMBIQ MICRO.

INFORMATION IN THIS DOCUMENT IS PROVIDED SOLELY TO ENABLE SYSTEM AND SOFTWARE IMPLEMENTERS TO
USE AMBIQ MICRO PRODUCTS. THERE ARE NO EXPRESS OR IMPLIED COPYRIGHT LICENSES GRANTED HEREUNDER
TO DESIGN OR FABRICATE ANY INTEGRATED CIRCUITS OR INTEGRATED CIRCUITS BASED ON THE INFORMATION IN
THIS DOCUMENT. AMBIQ MICRO RESERVES THE RIGHT TO MAKE CHANGES WITHOUT FURTHER NOTICE TO ANY
PRODUCTS HEREIN. AMBIQ MICRO MAKES NO WARRANTY, REPRESENTATION OR GUARANTEE REGARDING THE
SUITABILITY OF ITS PRODUCTS FOR ANY PARTICULAR PURPOSE, NOR DOES AMBIQ MICRO ASSUME ANY LIABILITY
ARISING OUT OF THE APPLICATION OR USE OF ANY PRODUCT OR CIRCUIT, AND SPECIFICALLY DISCLAIMS ANY
AND ALL LIABILITY, INCLUDING WITHOUT LIMITATION CONSEQUENTIAL OR INCIDENTAL DAMAGES. “TYPICAL”
PARAMETERS WHICH MAY BE PROVIDED IN AMBIQ MICRO DATA SHEETS AND/OR SPECIFICATIONS CAN AND DO
VARY IN DIFFERENT APPLICATIONS AND ACTUAL PERFORMANCE MAY VARY OVER TIME. ALL OPERATING
PARAMETERS, INCLUDING “TYPICALS” MUST BE VALIDATED FOR EACH CUSTOMER APPLICATION BY CUSTOMER’S
TECHNICAL EXPERTS. AMBIQ MICRO DOES NOT CONVEY ANY LICENSE UNDER NEITHER ITS PATENT RIGHTS NOR
THE RIGHTS OF OTHERS. AMBIQ MICRO PRODUCTS ARE NOT DESIGNED, INTENDED, OR AUTHORIZED FOR USE AS
COMPONENTS IN SYSTEMS INTENDED FOR SURGICAL IMPLANT INTO THE BODY, OR OTHER APPLICATIONS
INTENDED TO SUPPORT OR SUSTAIN LIFE, OR FOR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE
AMBIQ MICRO PRODUCT COULD CREATE A SITUATION WHERE PERSONAL INJURY OR DEATH MAY OCCUR.
SHOULD BUYER PURCHASE OR USE AMBIQ MICRO PRODUCTS FOR ANY SUCH UNINTENDED OR UNAUTHORIZED
APPLICATION, BUYER SHALL INDEMNIFY AND HOLD AMBIQ MICRO AND ITS OFFICERS, EMPLOYEES, SUBSIDIARIES,
AFFILIATES, AND DISTRIBUTORS HARMLESS AGAINST ALL CLAIMS, COSTS, DAMAGES, AND EXPENSES, AND
REASONABLE ATTORNEY FEES ARISING OUT OF, DIRECTLY OR INDIRECTLY, ANY CLAIM OF PERSONAL INJURY OR
DEATH ASSOCIATED WITH SUCH UNINTENDED OR UNAUTHORIZED USE, EVEN IF SUCH CLAIM ALLEGES THAT
AMBIQ MICRO WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE PART.
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SECTION

Introduction

This Getting Started Guide is designed to step a user through the first few screens for the J-Link

tools and for each of the IDEs in order to provide quick success with the new look and feel of
the AmbigSuite.
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Overview

This version of the AmbiqSuite SDK is designed to target a family of Arduino compatible Evalu-
ation Boards known as apollo1_evb and apollo2_evb. These boards are designed to be widely
compatible with the Arduino ecosystem of reference shield boards. In addition, they include a
SEGGER J-Link debugger on-board so there is no need for an external debugger.

This version supports example projects for the following toolchains:

= |AR Embedded Workbench 8.11.1
= Keil uVision 5.23

= Atollic TrueSTUDIO 7.1.2

= GCC5.3.1

Project templates are released for each toolchain. They are found in the subdirectories inside
each example project directory.

Figure 2-1: Example Project Directory

[= [ s
(€ I [ 48] [ Search cikout R
Oiganize > Include inlibrary »  Sharewith ~  New folder - 0 @
£ Pictures B Name ’ Date modified Type
B videos
atollic_gcc 5/5/201 File folder
& Homegroup L il folder
iar File folder
o Commpunes kel File folder
e | src File folder ||
$5y5Rese1 3 Makefile 5/5/2017 2:11 AM e
READMExt 5/5/2017211AM  TXTFile
95002500407¢f9d8b0d9dI3915ed?
845871784112f59447929edfdd
AmbigMicro
AmbiqDrivers
AmbigSuite
ambiq_ble
boards
apollo1_evb
apollo2_evb
bsp
examples
adc_Ipmode0
adc_Ipmodel
adc_Ipmode2
adc_read
binary_counter
clkout
coremark - il »
7 items

6 A-SOCAPG-GGGAO1EN v2.0



Updated to Windows PATH

Once the tools are installed, be sure to update the Windows PATH environment variable to
include the following additional paths (optional based on toolchain):

= C:\Program Files (x86)\Atollic\TrueSTUDIO for ARM 7.1.2\ARMTools\arm-atollic-eabi\bin
= C:\Program Files (x86)\Atollic\TrueSTUDIO for ARM 7.1.2\ARMTools\bin

= C:\Program Files (x86)\IAR Systems\Embedded Workbench 8.0\common\bin

= C:\Keil_v5\UV4
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J-Link Tools

The J-Link tools of interest are the J-Flash Lite and the J-Link SWO Viewer. J-Flash is used to load
pre-compiled binaries into the device flash. J-Link SWO Viewer is used to see the resulting

application output.

Figure 4-1: J-Link SWO Viewer

| SEGGER
| . J-Link V6.14f

ﬂ J-Flash Lite
J-Flash SPI
J-Flash
J-Link Commander
J-Link Configurator
J-Link DLL Updater
B8l )-Link GDB Server
J-Link JTAGLoad
J-Link License Manager
B )-Link RDI Config
J-Link Registration

E J-Link Remote Server
J-Link RTT Client
J-Link RTT Logger
J-Link RTT Viewer
J-Link SWO Viewer
ﬂ J-Mem
License Agreement

Remove J-Link V6.14f

| Manuals

| . Processor Specific Utilities

| Release Notes

EE J-Link Remote Server (Tunneling 1
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J-Link Tools

When J-Flash Lite is launched it may require configuration to the following (AMAPH1KK-KBR

and speed of 1000 or 1MHz).
Figure 4-2: SEGGER J-Flash Lite Configuration

(=] i

g T—
| SEGGER J-Flash Lite 6.14d
i

Target
Device

AMAPHIKK-KBR

Interface

] [swo

Speed

~|[000 ~|| oK |

Select a device

The J-Flash program itself just requires navigating to the proper directory (e.g. C:\AmbiqMi-
cro\AmbiqSuite\boards\apollo2_evb\examples\clkout\iar\bin\hello_world.bin) and selecting

Program Device. The result should look as follows:

Figure 4-3: SEGGER J-Flash Lite Program

B | SEGGER J-Flash Lite 6.14d SAEN X
File Help
Target
Device Interface Speed
AMAPH1KK-KBR SWD 1000
Data File .bin / Erase Start
C\AmbigMicro\AmbigSuite\boards\apolloZ_evb\examples\clkout\iar\bin\clkoutbin B Ox00000000

Program Device

)

Log

Interface@1000kHz
Programming Thread started.

Programming Thread exited
Programming done

Downloading C\AmbigMicro\AmbiqSuite\boards\apollo2_evb\examples\clkout\iar\bin\clkout.bin to AMAPH1KK-KBR via SWD-

Ready
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Next, start the J-Link SWO Viewer. Configuration is also required as follows:

Figure 4-4: J-Link SWO Viewer

SEGGER J-Link SWO Viewer V6.14d - Config o 23

Please enter the target CPU frequency or select a device for automatic
CPU frequency detection. Trace clock is usually CPU clock. On some
CPUs trace clock may have a different source.

Device: |.-5'-.M.-‘-'1|.F'H1 kE-KBR Select
TRACECLE [kHz]: |'| Q0o Measure

LCancel ‘

Note: Make sure the TRACECLK is set to 1000 or 1MHz.

Finally, press the SYSTEM RESET on the EVB and the program should run, displaying the fol-
lowing:

Figure 4-5: System Reset Running Program

K SEGGER J-Link SWO Viewer V6.14d L= - &S |

File Edit Help

. k]| 24 23 16 15 8 7 0
LR L2 ol e e I R R 2

[ Stayon top Clear | Stop | Pause I

=

»¥»333» CLEKOUT to LED Example
Clocks an LED about once a second based on the CLEOUT signal.

-~

« )

Device: AMAPH1KK-KER CPUFreq: 1000 kH=z SWOFreqgq: 1000 kHz 98 bytes
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Some of the examples require output on the UARTO which is also routed through the SEGGER
debug interface. The UART port is called JLink CDC UART Port and the settings for using the
UART are as follows:

Figure 4-6: Settings for Using the UART

Tera Term: Serial port setup lﬁ

e e |
Baud rate: 115200} -
Data: Cancel
Parity: m
stop: b
Flow control: [E

Transmit delay

0 msecichar 0 mseciline

Also note that it may be necessary to change the settings for the EOL to Line-Feed similar to
this:

Figure 4-7: Settings for the EOL to Line-Feed

Terminal size New-line o

80) X 48 Receive: |LF -

Term size = win size Transmit: Cancel

Auto window resize

Help
Terminal ID: |VT100 ~ | Local echo
Answerback: " | Auto switch (VT<->TEK)
Coding (receive) Coding (transmit)
UTF8 ~ UTF-8 =
locale: american CodePage: 635001
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Keil pVision MDK
Development Environment

The Keil MDK projects are set up to run the SWO output through the Debug (printf) Viewer.
This can be brought up by selecting View > Serial Windows >Debug (printf) Viewer. The out-
put appears as follows:

Figure 5-1: Debug (printf) Viewer Output

Boards projx - pVisio
Fie Edit View Project Flash Debug Periphercls Tooks SYCS Window Help
SHd @ | | ® [ @ A HALINTERRUH=] b 4 00 &[T 3
gl elooo o - DRSEDR- -E-2- 8- %
Ragisters n Diszssembly L]
Register lue - S E
5 Core o2 2
Dx100001EB = _
x100001E8 & i »
0x100001E8 e
01000018
00000000 =
R5 0x10000154
000000000
100000000

RO 0:00000000 »

£

RIT_— 000000000

RI12  Dx100001C4 67 ool bNewcClkout, boldclkout;

RI3(. Dx100011E8 68

R (. 000000177 69 r

RI5(. 0000115 70 // set the clock frequency.

8 XPSF 021000000 71 1
E1- Banied = 72 am_hal clkgen sysclk select (BM_HAL CLKGEN SYSCLK MRX) ;
= System 5 e = = SSE = =
=1 Intemal ‘ ’

Mode  Thread 4 e _

Privi..  Prvisged = :2 #/ Initialize peripherals as specified in the 35 i
Elpioect | B Registers ‘ = - B
Commana 2 B Dosug (rnty Viewer 2@
[

TraceSewupll; >33>>33 CLEOUT To LED Exampie
/fg_m flags = OX00000001: Clocks an LED about once a occond based on the CLXOUT signal.
_brdak_ - L
/7 sersp tor mnning
+ "Set_uidZMALElags ()"
s
/
1 3 =
f
B
ASSI6N DreskDisaple breaKEnaple BTeaKKill Breakiiss Breakses BIEAKAGCSss COVERAGT DEFING DIR Display Eater EVALuaze (P 0ebug (print Viewer [Ererery 1
J-LINK / )-TRACE Cortax 11: 330702233 sec L65C:1 CAP NUM SCRL OVR R /W,
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IAR Embedded Workbench

The IAR project can be selected inside the appropriate subdirectory by double-clicking on the
desired IAR IDE Workspace file. The project may be rebuilt as desired. When the debugger is
launched for the first time in the project, the following message is displayed:

Figure 6-1: Message After Launching Debugger
[ SEGGER J-Link SWO Viewer V6.14f - Config l& ]

Please enter the target CPU frequency or select a device for automatic
CPU frequency detection. Trace clock is usually CPU clock. On some
CPUs trace clock may have a different source.

Device: |AMAPHTKK-KER Select
TRACECLK [kHz]: |[1000 Measure

K. LCancel |

NOTE: The J-Link SWO Viewer has an interaction with the IAR Embedded Workbench such that the sequence of termi-
nating a debug session vs. shutting down the J-Link SWO Viewer matters. The proper order to avoid this problem is to

first terminate the debug session followed by shutting down the Viewer.

The output should be displayed as follows:
Figure 6-2: Debugger Display

m SEGGER J-Link SWO Viewer V6.14f

[

File Edit Help

3 24 23 18 15 8 7 0
Datattom stimais portsl. [~~~ T OO e

[ Stayontop Clear ] Stop | Pause |

>>>>>>> CLKOUT to LED Example
Clocks an LED about once a second based on the CLKOUT signal.

Device: AMAPHIKK-KER CPUFreq: 1000 kHz SWOFreq: 1000 kHz 97 bytes
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Atollic TrueSTUDIO

Use the following procedure to open existing projects in the Project Exporer:

1.

Launch the Atollic TrueSTUDIO and set up the workspace in:
C:\AmbigMicro\AmbiqSuite\boards

Wait for the Upgrade windows to finish (5 seconds) and close the window.
Select File >Import General > Existing Projects into Workspace.

Click Browse, then navigate to the /boards/<target> directory of interest (e.g., /boards/
apollo2_evb).

Click Finish to select all the projects, or de-select the unwanted projects. The Project
Explorer should appear as below:

&

GRS 168%™y -3 ~ 3~ |80 -E-8I Quick Access i| & [

= Project Explorer > B&le =0 = 0 % outi. % =8

+ & adc Ipmoded_gec

F adc_lpmodel_gec An outiine i not available.
% adc_lpmods2_gec
5 adc_read_gec

. G5 binary_caunter_gce

- [ clkout_gcd

+ @ coremark_gec

+ & deepsleap_gec

+ & deepsleap_wake_gec

» & flash_write_apallo?_gcc
» & flash_write_gcc

» & freertos_lowpower_gcc
» & hella_fault gec

+ € hello_world_gec

 hello_world_uart_gee
2 i2c loopback gcc
5 jos fifo_gee

- 25 ios fifo_hast_gec

- (25 itm_printf_gcc

+ G libam bsp_gec

+ & prime_gec

+ & pwm_gen_gcc

» € reset siates_gec

» € rtc_print_gec

» € stimer_gcc

+ & uart fifa_timeout gcc
+ € uart_printf gec

2 ulpbench_gee

2 ulpbench,lfrc_gcc %2 Problems 5t == O [ Buld Anayzer @ --8
2 watchdog_gcc Oerrors 5 wamings, D others _ DEMO MODE: Unlock this feature with a low-cest Pro subseription. Click here 1o learn more.
Description Resouroey patty Loc clkout.elf - /clkout_gec/bin - 5/5/17 9:52 AM
¢ & Warnings (3 items) [ | r———
Memory Regions | Memory Details
Region Start address  End address  Size Free Used Usage (%~
8 FLASH 0500000000 0x00100000 1024 K3 o
= SRAM 0510000000  0x10040000 256 K8
3 i

| L

B & dkoutgcc
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6. Select the clkout_gcc project.
7. Build the project.

8. Select debug. The debugger project should appear as follows:

Eile Edit View Run Window Help

S DS U W% b SRl I=R1- T -3 Quick Access | & | T
4 Debug &2 T % Break. 0 1 Registers 5 4B |3 o
€ clkout_gee bin [Embedded C/C++ Application] % & w | ® e Name Value Description

« @ clkout gecelf V|4 clkoutc [function: main] ¥4 General Registers General Purpose and FPU Reg
4  Thread #1 57005 (Suspended : Breakpoint)
= mainD a1 ckoutcT2 OK712
W C/Program Files (x86)/Atol lic/ TrueSTUDIO for ARM 7.1.2/ARMTools/bin/arm-atollic-eabi-gdb (7.10.1.2C
v SEGGER J-LINK

‘ i ' b
3 clkoutc e

& an_hal_clkgen_sysclk_select(AM HAL CLKGEN SYSCLK MAX); -

Initielize peripherels as specified in the BSP @ Fault Analyzer 35 =8

am_bsp_low_power_init(); ¢ DEMO MODE: Unlock this feature with a low-cost Pro subscription. Click
hete to leamn more.

Hard Fault Details

/ Initialize the printf interface for LTM/SWO output.

v

Bus Fault Details ¥

am_util_stdio_printf_init((an_util_stdio_print_char_t) am_bsp_itm_string_print); Usage Fault Details v

- Memory Management Fault Details v

o : Register Content During Fault Exception B
5 Initizlize the SWO GPIO pir

am _bsp pin_enable(ITM_SWO0);
& Terminal i1 =8 BEswv. =a
Fnable the TTH ) 2. ] r $ @ X| &gk +

D DEMO MODE: Unlock this feature with a
B Console 72| 0 Memory 58 FreeRTOS Task List B SW Trace Log B2 SWY Exception Trace Log £ Problems O Exacutables = Pro subscription. Click here to leam
EEETLIF -
cikour_gee bin [Embadsed C/C++ Application] C/Program Files (285)/Atollic/ TrueSTUDIO for ARM 7.1.2/ARMTools/bin/arm-arollic-2ani-gdb (7.10.1 20160210)
Breakpoint 1, main () at -.\..\src\clkout.c:72

2 am_hal_clkgen_sysclk_select(AM_HAL CLKGEN SYSCLK MAX);

B

il

NOTE: The J-Link SWO Viewer has an interaction with the TrueSTUDIO such that the sequence of
terminating a debug session vs. shutting down the J-Link SWO Viewer matters. The proper order

to avoid this problem is to first terminate the debug session followed by shutting down the
Viewer.
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Eclipse/GCC

NOTE: The Eclipse/GCC environment is not operational due to an unforeseen interaction

between the IDE and the J-Link GDB Server which has yet to be resolved.

The Eclipse environment is packaged into an Ambig-Tools installer which provides for the
installation of the required Java run-time environment, SEGGER J-Link tools, Arm GCC cross-

compiler tool chain, and the GNU Arm Eclipse build tools, as follows:

-
- AmbigTools Setup ﬁ
Prerequisites
These programs are needed for the application to run. Click on the check box
next to a prerequisite to select it for install or to skip it.
Name Version Action
[¥] 1ava Platform SE 8 U121 Found: nothing. Install
[¥] Jlink Required: 61210 or higher.... Install
ARM GCC Compiler 6.0 2017 g1 update Required: any. Found an a... Install
GNU Arm Eclipse Build Tools (64-bit) Found: nothing. Install
Press the Next button to install the prerequisites.
Back I[ Next ] l Finish ] l Cancel
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Use the following to select and build a project:
1. Follow the installation steps to get started with the Eclipse environment.
2. Once the tools are installed, the first step is to create a new workspace as follows:

E o
& Eclipse Launcher ﬁ

Select a directory as workspace

Eclipse uses the workspace directory to store its preferences and development artifacts.

Workspace:  C\AmbigMicro\AmbigSuite\boards\apollo2_evb -

[] Use this as the default and do not ask again

» Recent Workspaces

{ OK ] I Cancel l

3. After the standard Eclipse Welcome screen, the user may Import all the apollo2_evb proj-
ects by selecting Import, then select General > Existing Projects into Workspace, then
Browse, OK, and Finished. This should create a project screen that looks like this:

2 apollo2_evb - C_f(£++ —‘Echp -
| File Edit Source Refactor Mavigate Search Project Run Window Help

I -HG( 5% -BE-S-R-G-h-0-0-%- P /- REEIN S E-E-eeD

i
Quick Access ©| ¥ \@ N

7 Project Explorer 3% =8 Zgx % =g I
ER-A

> | adc_Ipmode0_gce An outling is not available.

> I adc_Ipmodel gce

> I adc_Ipmode2_gce

> 15 adc_read_gcc

- ¥ be_boot_demo_gec

> £ binary_counter_gcc

> I clkout_gce

B » = caremark gcc

4 0
£l

B © & deepsleep_gce

» &5 deepsleep_wake_gcc

> £ {lash_write_gcc

> 125 freertos_lowpower_gee
+ F hello_fault_gce

> & hello_world_gcc

: 5 hello_world_uart_gcc

> I itm_printf_gce

« £ libam_bsp_gcc
"1 multi_boat_gcc
> & pdm_plot_gce
> & pdm_voicerecog_gce
- [% reset_states_gec
» & rtc_print_gcc
» &5 stimer_gcc
. € yar fifo_timeout gee B Problems & & Tasks & Console [ Properties SRS
5 5 uart_printf_gec Oitems
(= watchdog_gee Description Resaurce Path Locatior

F— . e

-—w

LS adc_Ipmode0_gec {C/C++ Indexer: (45%) [

4. Next, select the desired project and then select Clean/Build the project.

17 A-SOCAPG-GGGAO1EN v2.0



Q) ambia

© 2022 Ambiq Micro, Inc. All rights reserved.

6500 River Place Boulevard, Building 7, Suite 200, Austin, TX 78730
www.ambig.com
sales@ambig.com
+1(512) 879-2850

A-SOCAPG-GGGAO1EN v2.0
September 2022



	Introduction
	Overview
	Figure 2-1 : Example Project Directory

	Updated to Windows PATH
	J-Link Tools
	Figure 4-1 : J-Link SWO Viewer
	Figure 4-2 : SEGGER J-Flash Lite Configuration
	Figure 4-3 : SEGGER J-Flash Lite Program
	Figure 4-4 : J-Link SWO Viewer
	Figure 4-5 : System Reset Running Program
	Figure 4-6 : Settings for Using the UART
	Figure 4-7 : Settings for the EOL to Line-Feed

	Keil µVision MDK Development Environment
	Figure 5-1 : Debug (printf) Viewer Output

	IAR Embedded Workbench
	Figure 6-1 : Message After Launching Debugger
	Figure 6-2 : Debugger Display

	Atollic TrueSTUDIO
	1. Launch the Atollic TrueSTUDIO and set up the workspace in: C:\AmbiqMicro\AmbiqSuite\boards
	2. Wait for the Upgrade windows to finish (5 seconds) and close the window.
	3. Select File >Import General > Existing Projects into Workspace.
	4. Click Browse, then navigate to the /boards/<target> directory of interest (e.g., /boards/ apollo2_evb).
	5. Click Finish to select all the projects, or de-select the unwanted projects. The Project Explorer should appear as below:
	6. Select the clkout_gcc project.
	7. Build the project.
	8. Select debug. The debugger project should appear as follows:

	Eclipse/GCC
	1. Follow the installation steps to get started with the Eclipse environment.
	2. Once the tools are installed, the first step is to create a new workspace as follows:
	3. After the standard Eclipse Welcome screen, the user may Import all the apollo2_evb projects by selecting Import, then select General > Existing Projects into Workspace, then Browse, OK, and Finished. This should create a project screen that looks ...
	4. Next, select the desired project and then select Clean/Build the project.


