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Legal Information and Disclaimers

AMBIQ MICRO INTENDS FOR THE CONTENT CONTAINED IN THE DOCUMENT TO BE ACCURATE AND RELIABLE. THIS
CONTENT MAY, HOWEVER, CONTAIN TECHNICAL INACCURACIES, TYPOGRAPHICAL ERRORS OR OTHER MISTAKES.
AMBIQ MICRO MAY MAKE CORRECTIONS OR OTHER CHANGES TO THIS CONTENT AT ANY TIME. AMBIQ MICRO
AND ITS SUPPLIERS RESERVE THE RIGHT TO MAKE CORRECTIONS, MODIFICATIONS, ENHANCEMENTS,
IMPROVEMENTS AND OTHER CHANGES TO ITS PRODUCTS, PROGRAMS AND SERVICES AT ANY TIME ORTO
DISCONTINUE ANY PRODUCTS, PROGRAMS, OR SERVICES WITHOUT NOTICE.

THE CONTENT IN THIS DOCUMENT IS PROVIDED "AS IS". AMBIQ MICRO AND ITS RESPECTIVE SUPPLIERS MAKE NO
REPRESENTATIONS ABOUT THE SUITABILITY OF THIS CONTENT FOR ANY PURPOSE AND DISCLAIM ALL
WARRANTIES AND CONDITIONS WITH REGARD TO THIS CONTENT, INCLUDING BUT NOT LIMITED TO, ALL IMPLIED
WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-
INFRINGEMENT OF ANY THIRD PARTY INTELLECTUAL PROPERTY RIGHT.

AMBIQ MICRO DOES NOT WARRANT OR REPRESENT THAT ANY LICENSE, EITHER EXPRESS OR IMPLIED, IS GRANTED
UNDER ANY PATENT RIGHT, COPYRIGHT, MASK WORK RIGHT, OR OTHER INTELLECTUAL PROPERTY RIGHT OF
AMBIQ MICRO COVERING OR RELATING TO THIS CONTENT OR ANY COMBINATION, MACHINE, OR PROCESS TO
WHICH THIS CONTENT RELATE OR WITH WHICH THIS CONTENT MAY BE USED.

USE OF THE INFORMATION IN THIS DOCUMENT MAY REQUIRE A LICENSE FROM A THIRD PARTY UNDER THE
PATENTS OR OTHER INTELLECTUAL PROPERTY OF THAT THIRD PARTY, OR A LICENSE FROM AMBIQ MICRO UNDER
THE PATENTS OR OTHER INTELLECTUAL PROPERTY OF AMBIQ MICRO.

INFORMATION IN THIS DOCUMENT IS PROVIDED SOLELY TO ENABLE SYSTEM AND SOFTWARE IMPLEMENTERS TO
USE AMBIQ MICRO PRODUCTS. THERE ARE NO EXPRESS OR IMPLIED COPYRIGHT LICENSES GRANTED HEREUNDER
TO DESIGN OR FABRICATE ANY INTEGRATED CIRCUITS OR INTEGRATED CIRCUITS BASED ON THE INFORMATION IN
THIS DOCUMENT. AMBIQ MICRO RESERVES THE RIGHT TO MAKE CHANGES WITHOUT FURTHER NOTICE TO ANY
PRODUCTS HEREIN. AMBIQ MICRO MAKES NO WARRANTY, REPRESENTATION OR GUARANTEE REGARDING THE
SUITABILITY OF ITS PRODUCTS FOR ANY PARTICULAR PURPOSE, NOR DOES AMBIQ MICRO ASSUME ANY LIABILITY
ARISING OUT OF THE APPLICATION OR USE OF ANY PRODUCT OR CIRCUIT, AND SPECIFICALLY DISCLAIMS ANY
AND ALL LIABILITY, INCLUDING WITHOUT LIMITATION CONSEQUENTIAL OR INCIDENTAL DAMAGES. “TYPICAL”
PARAMETERS WHICH MAY BE PROVIDED IN AMBIQ MICRO DATA SHEETS AND/OR SPECIFICATIONS CAN AND DO
VARY IN DIFFERENT APPLICATIONS AND ACTUAL PERFORMANCE MAY VARY OVER TIME. ALL OPERATING
PARAMETERS, INCLUDING “TYPICALS” MUST BE VALIDATED FOR EACH CUSTOMER APPLICATION BY CUSTOMER’S
TECHNICAL EXPERTS. AMBIQ MICRO DOES NOT CONVEY ANY LICENSE UNDER NEITHER ITS PATENT RIGHTS NOR
THE RIGHTS OF OTHERS. AMBIQ MICRO PRODUCTS ARE NOT DESIGNED, INTENDED, OR AUTHORIZED FOR USE AS
COMPONENTS IN SYSTEMS INTENDED FOR SURGICAL IMPLANT INTO THE BODY, OR OTHER APPLICATIONS
INTENDED TO SUPPORT OR SUSTAIN LIFE, OR FOR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE
AMBIQ MICRO PRODUCT COULD CREATE A SITUATION WHERE PERSONAL INJURY OR DEATH MAY OCCUR.
SHOULD BUYER PURCHASE OR USE AMBIQ MICRO PRODUCTS FOR ANY SUCH UNINTENDED OR UNAUTHORIZED
APPLICATION, BUYER SHALL INDEMNIFY AND HOLD AMBIQ MICRO AND ITS OFFICERS, EMPLOYEES, SUBSIDIARIES,
AFFILIATES, AND DISTRIBUTORS HARMLESS AGAINST ALL CLAIMS, COSTS, DAMAGES, AND EXPENSES, AND
REASONABLE ATTORNEY FEES ARISING OUT OF, DIRECTLY OR INDIRECTLY, ANY CLAIM OF PERSONAL INJURY OR
DEATH ASSOCIATED WITH SUCH UNINTENDED OR UNAUTHORIZED USE, EVEN IF SUCH CLAIM ALLEGES THAT
AMBIQ MICRO WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE PART.
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Introduction

The open source Eclipse IDE is not formally supported in AmbiqSuite SDK and only limited tests
are performed. AmbiqSuite does support GCC makefiles and all examples compiled and tested
in the environment. This application note provides a step-by-step procedure to setup Eclipse
development and debugging environment on machines running Windows operating systems.
In this document, Windows 10 64-bit is used an example. It outlines the open source tools that
need to be downloaded, but the user should keep in mind that these tools change quite rap-
idly and some research may be required to get the latest versions.
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Installation

Use the following procedure to install:

1. Java Runtime Environment (JRE) or Java Development Kit (JDK)
= JREis sufficient for our usage.
= https://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

=  Make sure JRE is in Windows environment variable Path.

2. GNU MCU Eclipse Arm Embedded GCC
» Download from https://github.com/gnu-mcu-eclipse/arm-none-eabi-gcc/releases/
= Extract and place it to a proper location and add this path to Windows environment vari-
able Path.

3. GNU MCU Eclipse Windows Build Tools
=  Download from https://github.com/gnu-mcu-eclipse/windows-build-tools/releases
= Extract and place it to a proper location.

For example:

V] s | GNU MCU Eclipse

Home Share View
<« v P C:\GNU MCU Edlipse

Name

# Quick access
ARM Embedded GCC
& OneDrive Build Tools

<& This PC

¥ Network
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Eclipse Environment Setup Application Note Installation

4. GNU MCU Eclipse IDE for C/C++ Developers
» Download from https://github.com/gnu-mcu-eclipse/org.eclipse.epp.packages/
releases. Make sure the version matches the installed JRE, both 32-bit version or 64-bit.

= Extract and place it to a proper location.

5. J-Link Software and Documentation pack for Windows
= Download from https://www.segger.com/downloads/jlink/#J-LinkSoftwareAndDocu-
mentationPack and install it.
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Eclipse Setup

Use the following procedure to setup Eclipse:

1. Launch Eclipse and you will be asked to setup a workspace which can be anywhere.

2. In Eclipse, navigate to Window > Preferences. In the left panel, unfold MCU and configure
Global Arm Toolchains Paths, Global Build Tools Path and Global SEGGER J-Link Path.

& Preferences a Y,

lype filler text Global ARM Toolchains Paths
~ MCU n
Global ARM Toolchains Paths
Global Build Tools Path

Globel Jumper Path
Glohal Open0CD Path Toolchain name:  GNU MCU Eclipse ARM Embeddsd GCC

Configure the locations where various GNU ARM toolchaing are installed. The values are stored within Eclipse. Unless redefined more
spedifically, they are used for all projects in all workspaces.
Default toeldchain: GNU MCU Edipse ARM Embedded GCC ¥

Global pyOCD Path Toolchain folder: | CYGNU MCU Eclipse\ARM Embedded GCCL/.3.1-1.1-20180724-063/bin Browsa,
Global QEMU Path
Globel RISC-V Toulchains Faths
Global SEGGER J-Link Path
Workspace ARM Toolchains Paths
Workspace Build Tools Path
Workspace lumper Path
Workspace OpenQCD Path
Workspace pyQCD Path
Waorkspace QCMU Path
Workspace RISC-V Toolchains Paths
Workspace SEGGER J-Link Path

Mylyn

Oomph

Femaote Developrment

RPM

Run/Diebug

Taam

R W Apply and Close Cancel

2 Restore Defaults Apply

—_
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Eclipse Setup

& Preferences

type filter text
v MCU

>

Global ARM Toolchains Paths

Global Build Tools Path

Global Jumper Path

Global OpenOCD Path

Global pyOCD Path

Global QEMU Path

Global RISC-V Toolchains Paths

Global SEGGER J-Link Path

Workspace ARM Toolchains Paths

Workspace Build Tools Path

Workspace Jumper Path

Workspace OpenOCD Path

Workspace pyOCD Path

Workspace QEMU Path

Workspace RISC-V Toolchains Paths

Workspace SEGGER J-Link Path
Mylyn

> Oocmph

>
>
>

Remote Development
RPM
Run/Debug

Team

Global Build Tools Path

The locations where various GNU MCU Eclipse build tools are installed. Unless defined more specifically, they are used for all projects in
all workspaces.

Build tools folder: | C:AGNU MCU Edlipse\Build Tools\2.11-20180428-1604\bin Browse... xPack...

Restore Defaults Apply

D@

@ Preferences

type filter text

¥ MCU

Global ARM Toolchains Paths
Global Build Tools Path

Global Jumper Path

Global OpenOCD Path

Global pyQCD Path

Global QEMU Path

Global RISC-V Toolchains Paths
Global SEGGER J-Link Path
Workspace ARM Toolchains Paths
Workspace Build Tools Path
Workspace Jumper Path
‘Workspace OpenOCD Path
Workspace pyOCD Path
Workspace QEMU Path
Workspace RISC-V Toolchains Paths
Workspace SEGGER J-Link Path

Mylyn

> Oomph

>

»
’

Remote Development

> RPM

Run/Debug

Taam

Apply and Close

Cancel

Global SEGGER J-Link Path

Configure the location where SEGGER J-Link is installed. The values are stored within Eclipse. Unless redefined more specifically, they are
used for all projects in all workspaces.

After installing SEGGER updates, restart Eclipse for the defaults to be re-evaluated and use the Restore Defaults button to configure the
new location.

Executable: | JLinkGDBServerCLexe

Folder; | C:/Program Files (x86)/SEGGER/ILink_V640/

Browse... xPack.

Restore Defaults

Apply

Cancel
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Project Import and

Compilation

Use the following procedure to import and compile projects:

% Import

Select

Creates a new Makefile project in a directory containing existing code

Select an import wizard:
type filter text
& General
v & C/C++
[e] C/C++ Executable
&2 C/C++ Project Settings
£ Existing code as Autotools project
k] Existing Code as Makefile Project
& Git
& Install
& Oomph
& RPM
& Run/Debug
> Tasks
& Team
& TextMate
& Tracing
= XML

Cancel

1. In Eclipse, navigate to File >Import. Select C/C++>Existing Code as Makefile Project. Click
Next. For projects which are to be imported for the first time use this option. For those proj-
ects which have previously been imported to Eclipse (check if the files, .project and .cproj-
ect, and the folder .settings exist in <project>/gcc,) select General >Existing Projects

into Workspace.

\

=
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Eclipse Environment Setup Application Note Project Import and Compilation

2. Select the targeting project. Take the project clkout of R2.0 for Apollo3 as an example.

= Change the project name (optional).
= Select ARM Cross GCC in Toolchain for Indexer Settings.

£ New Project O X
Import Existing Code

Create a new Makefile project from existing code in that same directory

Project Name

clkout_eclipse_gcc |

Existing Code Location

nace\ambigqsuite-rel1.2.12\board s\apollo2_evb\examples\clkout\gcd ‘ Browse...

Languages

C C++

Toolchain for Indexer Settings

<none>

ARM Cross GCC

Cross GCC

Cygwin GCC

GNU Autotools Toolchain
RISC-V Cross GCC

Show only available toolchains that support this platform

@ < Back Next > Cancel

3. After the project is imported, the project explorer shows the project like the following
screenshot.

& Project Explorer B®|le v=0
v &5 > clkout_eclipse_gcc [ambigsuite-rel1.2.12 master]

& bin

l% > startup_gcc.c

5 > clkout.Id

@ > Makefile
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4. Right click on the project and go to Properties > C/C++ Builds > Build Variables. Add two
variables as highlighted in below. Click Apply and Close.

[=] Properties for clout_eclipse_gec O X
type filter text Build Variables A g
> Resource

Builders .
~ C/C++ Build Configuration: Default [ Active ] ¥ Manage Configurations...

Build Variables
Environment

Logging Name Type Value | Add...\;
Settings cross_ make String make o [s
Tool Chain Editor cross_prefix String arm-none-eabi- i
» CfC++ General Deletoe
Git
Linux Tools Path
> MCU

Project Natures
Project References
Run/Debug Settings

> Task Repositol
g ki [_] Show system variables

Task Tags
» Validation
WikiText Build Variables are IDE only variables, which can be used for string substitution when defining external builder configuration,
such as environment variable value or command line parameter in form of ${VAR}, internal builder may use them directly.
Restore Defaults Apply
7 Apply and Close Cancel

5. Right click on the project and select Clean Project.

B Console #

CDT Build Console [clout_eclipse_gcc]

17:14:13 **** Clean-only build of configuration Default for project clout_eclipse_gcc ****
make clean
Cleaning...

17:14:13 Build Finished. © errors, @ warnings. (took 317ms)

6. Right click on the project and select Build Project.

oblems asks B Console 2 I Properties

CDT Build Console [clout_eclipse_gec]

17:22:1e **** Buyild of configuration Default for project clout_eclipse_gcc ****
make all
Compiling gcc ../
Compiling gcc ../.
Compiling gcc ../.
Compiling gcc ../.
Compiling gcc ../.
Compiling gcc startup_gcc.c
Linking gcc bin/clkout.axf
Copying gcc bin/clkout.bin...

src/clkou

s /utlls/am util_delay.c
./../utils/am_util_faultisr.c
./../utils/am_util_stdio.c
./../devices/am_devices_led.c

c/cl
il il
ST
5y
Y

17:22:11 Build Finished. @ errors, @ warnings. (took 1s.376ms)
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SECTION

Project Debugging

Use the following procedure to debug a project:

1. Navigate to Run > Debug Configurations.

& Debug Configurations [m] b4
Create, manage, and run configurations ‘ﬁ\-
o B B Xeg®~r ‘Confi launch settings from this dialog:
type filter text ||| I - Prass the ‘New Configuration’ button to create a configuration of the selected type.

) £/Cx++ Application I# - Press the 'New Prototype' button to create a launch configuration prototype of the selected type.

& C/C++ Attach to Application

[ C/C++ Conitainer Launchir <& - Press the ‘Export’ button to export the selected configurations.

[ C/C++ Postmortem Debugger ¥ - Press the "Duplicate’ button to copy the selected configuration.

1 C/C++ Remote Application % - Prass the ‘Delete’ button to remove the selected configuration.

Cil C/C++ Unit

- P 'Fi i i ions.

) GDB Hardware Debugging ress the Filter' button to configure filtering options.

E GDB Jumper Debugging - Edit or view an existing configuration by selecting it.

[ GDB OpenOCD Debugging sl - Select launch configuration(s) and then select ‘Link Prototype’ menu item to link a prototype.

IH GDE hyGeD Debbugglng 1w/ - Select launch configuration(s) and then select ‘Unlink Prototype’ menu item to unlink a prototype.

& GDB QEMU Debugging

1 GOB SEGGER J-Link Debugging I8l - Select launch configuration(s) and then select ‘Reset with Prototype Values' menu item to reset with prototype values.

A Launch Group

& Launch Group (Deprecated) Configure launch perspective settings from the 'Pecspectives’ preference page.

Filter matched 14 of 14 items

@ Debug Close

2. Right click on GDB SEGGER J-Link Debugging and select New Configuration.
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Eclipse Environment Setup Application Note Project Debugging

3. In Main page, make sure Project has the name identical to the one set in project import and
C/C++ Application pointed to the corresponding .axf file.

& Debug Configurations [} s
-
Create, manage, and run configurations @.
Il B RE e Name: | clout_eclipse_gec Default
type filter text = -
Ve ter tex =l Main . % Debugger ¥ Startup & Source ™ Common 7. SVD Path
[E C/C++ Application .
[E] C/C++ Attach to Applicajon B
E C/C++ Container Launch clout_eclipse_gec Browse..
[ C/C++ Postmortem Debllgge | | C/C++ Application:
[E] C/C++ Remote Applicatign bindkout.axf
Cif C/C++ Unit
(= GDB Hardware Debuggi Variables... Search Project... Browse..
[¥1 GDB Jumper Debugging Build (if required) befare launching
£ GDB OpenOLD Debugging Build Configuration: Select Automatically ¥
[€1 GDB PyOCD Debugging . _
= GDB QEMU Debugging L_! Enable auto build (U Disable auto build
~ [E] GDB SEGGER J-Link Debugagit @' Use workspace settirlgs Configure Workspace Settings...
1 clout_edlipse_gecc Default
# Launch Group
# Launch Group (Deprecated)
< >
Filter matched 15 af 15 itemns Kevat Apply
@ Close
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Eclipse Environment Setup Application Note Project Debugging

4. In Debugger page, make sure Actual executable is correctly interpreted and Device name is
added.

& Debug Configurations | P

Create, manage, and run configurations ﬁ

i ERBEXIEF Mame: | clout_eclipse_gee Default

type filter text
[E1C/C++ Application
€] C/C++ Attach to Application
EC/C++ Container Launch
€1 C/C++ Postmortem Debfigge
€] C/C++ Remote Applicati

E Main[*f- Debugger-"x? Slartuplfé Source [ Common | & SVD Path|
J-Link GDB Server Setup
Start the J-Link GDB server locally [ |connect to running target

Executable path: | ${ilink_path}/S{jlink_gdbserver} Browse... |Variablfs...

Actual execulahle:| C:/Pragram Files (x86)/SEGGER/ILink V640//ILinkGDBServerCL exe

=

0 C/C++ Unit (to change it use the global or workspace preferences pages or the project properties padge)
[E1GDB Hard Deb i
—— i war; he u?gm Device name: AMAPH1KK-KBR. Supported device nafines
< LIITIPEI' (= uggmg

Endianness: (@ Litte () Big

[E1GDB OpenOCD Debugging )

€1 GDB PyOCD Debugging Connection: @®use O | {USB serial or IP name/address)
[£1GDE QEMU Debugging Interface: ®swo OJIAG
v [1GDB SEGGER J-Link Debuggit | Intial speed: (O Auto () Adap: @) Fixed | 1000 | kHz

Dogebieh | gupr [

# Launch Group (Deprecated) SWQ port: | 2332 [¥] Verify downloads Initialize registers on start
Telnet port: 2333 Local host only  [] Silent
Log file: | Browse...
Other options: | -singlerun -strict -timeout 0 -nogui

Allocate console for the GDB server Allocate console for semihosting and SWO

GDB Client Setup
Executable name: | ${cross_prefiigdb$icross_suffix} Browse... |Variables...

Actual executable: | arm-none-eabi-gdb |

Other options: | |

Commands: set mem inaccessible-by-default off

Remote Target
Host name or IP address: localhost

Part numhber: 2331

[ Force thread list update on suspend

Restore defaults

£ >
Filter matched 15 of 15 items

®

Rewert Apply
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Eclipse Environment Setup Application Note

Project Debugging

5. In SVD page, add the path to the targeting board SVD file located in <SDK>/pack. Click
Apply and Debug.

[e

Debug Configurations

Create, manage, and run configurations

FEEEICEE

type filter text

<

[E C/C++ Application

[E] C/C++ Attach to Application

[E C/C++ Container Launcher

[ C/C++ Postmortern Debugge

[ C/C++ Remote Application

0 CAC++ Unit

£ GDB Hardware Debugging

[€1GDR Jumper Debugging

[E1 GDB OpenOCD Debugging

[£1GDB PyOCD Debugging

[£] GDB QEMU Debugging

[ GDB SEGGER J-Link Debuggir
] clout_eclipse_gecc Default

# Launch Group

# Launch Group (Deprecated)

Filter matched 15 of 15 items

Name: | clout_eclipse_gee Default

=l Main | % Debugger | ® Startup | % Source | = Common 7: 5VD Path
SVD file (used by the peripheral registers viewer)

File

space\ambiqsuite-rel1.2.12\pack\SVD\a polloE.svc‘ Browse... Variables...

Reyert Apply
Close
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Eclipse Environment Setup Application Note Project Debugging

6. After the debugger is launched, the program stops at the main function. Click the run icon
highlighted in the red frame below. The LEDs on EVB shall start to blink.

ALl Tien\ Diocusmantsworkepaceiambigruste-relt 2 1 4 boardd\apclia? svbieampleddioutiurddiout c - Ecipes 106

I 1 T I : . inm

*+ Variables * Broakpoins *7 Expressions & Modules . Peripherals

int32_t iRisinglount, iLEDcount; -
bool bewClkout, bOldClkout; -
trel
| B am_hal_clikgen_sysclk_salect{AM_HAL_CLKGEN_SYSCLK_MAX)
figuration
am_hal_cachectrl_srable(Sem_hal_cachectrl_defaults);
OMSTRA DrSO008_ (/5P Marster il
¢ >
am_bsp_low_power_init();
am_util_stdio_printf init{{am _util_stdio_print_char_t) am_bsp_itm_string v
< »

O Console . Qv
GHL MO Ecipae Packs consale

2018-11-23 17:34:05
Parsing 5V0 file “C:\Users\LTien\Docusents'workspace'\smbigsuite-rell.2. 12%pack \5¥Dhapollod.svd™. ..
Completed in Slms
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Troubleshooting

Make sure Windows Environment variable Path is configured correctly. For Windows 10,
right click on This PC and navigate to Properties > Advanced system settings > Environ-
ment Variables, and check the variable Path.

2. Contact regional Ambiq Field Application Engineers if you encounter further questions.
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